Follow

Course Selector

 

Our Course Options Module enables schools to easily collect information from students regarding their plans for the next academic year.

The following describes the general procedure for setting up and configuring the Course Options module. Please make sure you have turned on this module before you start.

  1. Go to Tools > Administration > Configuration Options > General Config
  2. From the Select Modules area use the check box to enable Course Options
  3.  Click Save to update your configuration.

    select_modules_screen.GIF

 

Once the Course Options have been setup and configured by the KnowledgeNET Administrator students will be able to access and select courses under My Zone.

 

Student View

My_Course_Options.GIF

Upload Courses

Use our spreadsheet to be able to quickly create your course options in KnowledgeNET.

  1. Go to Tools > Administration > Course Selector > Upload Courses
  2. Download our sample CSV file.
  3. In this file enter/copy the following information:
    • Course Year Level e.g. 10
    • Course Code e.g. 2012graphics10
    • Course Name e.g. Graphics
    • Course Department e.g. Arts
  4. Once your spreadsheet is complete and save go back to Tools > Administration > Course Selector > Upload Courses and press upload.GIFto browse your computer for the file.
  5. Select your file and click OK. This may take some time to process.

If you do not wish to use a spreadsheet to manage your courses go to Tools > Administration > Course Selector > Manage Courses and manually enter course details by pressing add_button.GIF. Go here to also Edit or Delete a course by clicking Action next to the course titleCourses cannot be edited or deleted if a student has already submitted selections for next year, this is to prevent corruption of the existing student submissions, however Courses can be deleted or edited if the student submissions are leaver forms and not course selections.

 

Leaver Plans

 

Students who are NOT planning on returning next year can select select "I will not be returning in 20..." and then they can choose from a list of leavers plans, that you entered e.g. "seeking full-time employment", "full time employment arranged", "Apprenticeship Gained", "Gap Year", "Tertiary Education" etc 

 

Add, edit or delete leavers plans by  go to:

  1. Tools > Administration > Course Selector > Leavers Plans and press add_button.GIFto enter new leavers plan.
    • Title – displayed to the students e.g. "Gap Year
    • Roll-over Description – used as the tool-tip text on mouse-over for students
    • Short Code – 
    • Display Order – determines the order in which plans are displayed - use alpha sequence A- Z

Two of the plans, “Tertiary Education” and “Attending another secondary school” are part of the system and therefore cannot be deleted or edited. 

 

Leaver University Options

 

Leaver uni options represent the tertiary institutions which students can select in the leavers form these are only relevant if students choose “Tertiary Education” for their leaving plan.

From here you can add, edit or delete plans one by one. 

  1. Tools > Administration > Course Selector > Leaver University Options and press add_button.GIF.
  2. Configure the following options:
    • Title – displayed to the students e.g University of Aucland
    •  Roll-over Description – used as the tool-tip text on mouse-over for students
    •  Short Code – 
    •  Display Order – determines the order in which plans are displayed - use alpha sequence A- Z 

 

Leaver Study Areas

 

Leaver study areas represent the tertiary study areas which students can select in the leavers form, these are only relevant if students choose “Tertiary Education” for their leaving plan.

From here you can add, edit or delete plans one by one. here is a breif outline of the option fields:

Available under Tools → Administration → Course Selector > Leaver Study areas

  •  
    • Title – displayed to the students e.g. Law
    • Roll-over Description – used as the tool-tip text on mouse-over for students
    • Short Code – 
    • Display Order – determines the order in which plans are displayed - use alpha sequence A- Z

 

Reports

Allows you to view submissions made by students. If students have not entered any submissions this list will be blank.

Available under Tools → Administration → Course Selector

  • Print
  • Prints the current page
  • Download All 
  • Downloads ALL the submissions in the database, ignoring the search conditions, as a CSV file
  • Download Selected
  • Downloads all the SELECTED submissions as a CSV file
  • Delete Selected
  • Deletes all the SELECTED submissions
  • Select All
  • Selects all the submissions on the CURRENT PAGE

 

Configuration

 

Available under Tools → Administration → Course Selector

 

Allows administrators to set the configuration variables for the module: 

  • Title to display under My Zone menu – this determines what the menu item will be displayed as for students, under their My Zone menu e.g My Course Options
  • Display name of course/subject/option (singular) – this will replace the word “Course” in menus and pages of the module
  •  Display name of course/subject/option (plural) – this will replace the word “Courses” in menus and pages of the module
  • Allow caregivers to view (read only)
  •  Year level-specific settings – for each year level present in the school database, a set of settings will be present:
    • Number of Courses that students must select – determines the number of courses students must select. Setting this to 0 will disable the course selection form for the students and only enable the leavers form
    •  Enable – determines whether the forms will be available for students or not, combined with the Enable it from date, see below.
    •  Enable it from – determines the date from which the forms will be available
    •  Enable it until – determines the date until which the forms will be available i.e. students must enter their selections before this date. Once past this date, the forms will be disabled; however, students will still be able to access the pages and view their submissions.

 

DELETE ALL

This option will only display if student submissions exist, clicking on the Delete All button will delete ALL student selections where students have selected to return to school next year

Was this article helpful?
1 out of 1 found this helpful
Have more questions? Submit a request

2 Comments

  • 0
    Avatar
    Lynda Fairweather

    The KN2010 version we are using shows this module as "Subject Selector" not "Course Selector"?

  • 0
    Avatar
    Serena Harris

    @

    Edited by Serena Harris
Please sign in to leave a comment.
Powered by Zendesk